VRRP для Mikrotik’а для увеличения доступности маршрутизаторов

VRRP пример на mikrotik от blog.wel.org.ua

Протокол VRRP предназначен для увеличения доступности маршрутизаторов выполняющих роль шлюза по умолчанию.

VRRP (Virtual Router Redundancy Protocol) — сетевой протокол, предназначенный для увеличения доступности маршрутизаторов выполняющих роль шлюза по умолчанию. Это достигается путём объединения группы маршрутизаторов в один виртуальный маршрутизатор и назначения им общего IP-адреса, который и будет использоваться как шлюз по умолчанию для компьютеров в сети.

В принципе, по описанию все довольно просто.

VRRP пример на mikrotik от  blog.wel.org.ua

VRRP пример на mikrotik от blog.wel.org.ua

Итак, настраиваем первый Mikrotik – R1:

1
2
3
/ip address add address=172.16.10.1/24 interface=ether1
/interface vrrp add interface=ether1 vrid=49 priority=254
/ip address add address=172.16.10.254/32 interface=vrrp1

На втором Mikrotik‘е – R2:

1
2
3
/ip address add address=172.16.10.2/24 interface=ether1
/interface vrrp add interface=ether1 vrid=49
/ip address add address=172.16.10.254/32 interface=vrrp1

Меньший priority имеет VRRP Backup router(резервный) . По умолчанию priority равен 100.

Проверяем на R1:

1
2
3
4
/interface vrrp print
 0   RM name="vrrp1" mtu=1500 mac-address=00:ff:aa:11:00:ff arp=enabled interface=ether1 vrid=49
        priority=254 interval=1 preemption-mode=yes authentication=none password="" on-backup=""
        on-master=""

Проверяем на R2:

1
2
3
4
/interface vrrp print
 0    B name="vrrp1" mtu=1500 mac-address=00:ff:aa:11:00:ff arp=enabled interface=ether1 vrid=49
        priority=100 interval=1 preemption-mode=yes authentication=none password=""
        on-backup="" on-master="

Результат, MAC одинаков на обоих роутерах. Ну и окончательная проверка. Пингаем из сети адрес 172.16.10.254 и выдергиваем сетевой кабель из R1. Пинг будет продолжать идти.

Таким же образом можно дублировать и внешний канал.

/interface vrrp
Свойство Описание
interface (string; Default: ) Interface name on which VRRP instance will be running
vrid (integer: 1..255; Default: 1) Virtual Router identifier. Each Virtual router must have unique id number
priority (integer: 1..254; Default: 100) Priority of VRRP node used in Master election algorithm. Higher number means higher priority. ‘255’ is reserved to Router that owns VR IP and ‘0’ is reserved for Master router to indicate that it is releasing responsibility.
interval (integer: 1..255; Default: 1) VRRP update interval in seconds. Defines how often master sends advertisement packets.
preemption-mode (yes|no; Default: yes) Whether master node always has the priority. When set to ‘no’ backup node will not be elected to be a master until the current master fails, even if the backup node has higher priority than the current master. This setting is ignored if Owner router becomes available
authentication (ah,none,simple; Default: none) Authentication method to use for VRRP advertisement packets.

  • none — should be used only in low security networks (e.g., two VRRP nodes on LAN).
  • ah — IP Authentication Header. This algorithm provides strong protection against configuration errors, replay attacks and packet corruption/modification. Recommended when there is limited control over the administration of nodes on a LAN.
  • simple — uses clear text password. Protects against accidental misconfiguration of routers on local network.
password (string; Default: ) Password required for authentication. Can be ignored if authentication is not used.
name (string; Default: ) VRRP interface name
on-backup (string; Default: ) Script to execute when the node switch to backup state
on-master (string; Default: ) Script to execute when the node switch to master state

Leave a Comment

Ваш e-mail не будет опубликован. Обязательные поля помечены *

Загрузка...
Menu Title