Как заблокировать сайты на Mikrotik с использованием прокси

Как заблокировать сайты на Mikrotik с использованием прокси или же узнать в другой статье Как заблокировать вКонтакте, Одноклассники, Мой мир или любой сайт в Mikrotik с помощью DNS или Firewall.
В этот примере мы с Вами рассмотрим как заблокировать веб-узел и как остановить закачку.

Настройка прокси:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
/ip proxy
set enabled: yes
set src-address: 0.0.0.0
set port: 8080
set parent-proxy: 0.0.0.0:0
set cache-drive: system
set cache-administrator: "webmaster"
set max-disk-cache-size: none
set max-ram-cache-size: none
set cache-only-on-disk: no
set maximal-client-connections: 1000
set maximal-server-connections: 1000
set max-object-size: 512KiB
set max-fresh-time: 3d

Теперь, сделать его прозрачным в firewall

1
2
/ip firewall nat
add chain=dstnat protocol=tcp dst-port=80 action=redirect to-ports=8080

Далее

1
2
/ip firewall filter
add chain=input in-interface= src-address=0.0.0.0/0 protocol=tcp dst-port=8080 action=drop

Теперь для блокирования веб-сайтов

1
2
/ip proxy access
add dst-host=www.blogfreebsd.com action=deny

Мы также можем остановить загрузку файлов с различными файлами mp3, .exe, .dat, .avi

1
2
3
4
5
6
7
8
/ip proxy access
add path=*.exe action=deny
add path=*.mp3 action=deny
add path=*.zip action=deny
add path=*.rar action=deny
 
/ip proxy access
add dst-host=:mail action=deny

При этом блокируются все сайты содержат слово “почта” в URL. Пример: Это будет блокировать www.hotmail.com, mail.yahoo.com, www.rediffmail.com

На этом все!


Leave a Comment

Ваш e-mail не будет опубликован. Обязательные поля помечены *

Загрузка...
Menu Title