Глава 3. Краткое сравнение Cisco и Vyatta команд

Глава 3. Краткое сравнение Cisco и Vyatta команд

Автор г-н Кандра

Режим (Mode):

Cisco Prompt Режим Vyatta Prompt Режим
Router> Пользовательский [email protected]:~$ Operational Mode
Router# Привилегированный [email protected]# Configuration mode
Router(config)# Global Configuration Mode
—– VYATTA OPERATIONAL MODE COMMANDS —–
ping

traceroute
show arp

show ip ospf neighbor

show ip ospf database

show ip ospf neighbor detail

show ip ospf border-routers

show ip route

show ip route bgp

show ip route ospf

show ip route connected

show ip route rip

show ip route static

show ip interfaces

show clock

show ip dhcp binding

show ip dhcp server statistics

show vrrp all

show ip nat translations

show ip nat statistics

ping

traceroute

show arp

show ip ospf neighbor

show ip ospf database

show ip ospf neighbor detail

show ip ospf border-routers

show ip route

show ip route bgp

show ip route ospf

show ip route connected

show ip route rip

show ip route static

show interfaces

show host date

show dhcp leases

show dhcp statistics

show vrrp

show nat translations

show nat statistics

—– VYATTA CONFIGURATION MODE COMMANDS —–
SAVE
copy run start save
SHOW
show running-config show
HELP
? ?
SET SERVICE
ip http server

line vty 0 4

password

crypto key generate rsa

(only on some IOS versions)

set service https

set service telnet

set service ssh

DHCP
ip dhcp pool mydhcp

network 192.168.0.0 255.255.255.0

default-router 192.168.0.1

dns-server 192.168.100.1

ip dhcp excluded-address 192.168.0.1 192.168.0.10

set service dhcp-server shared-network-name mydhcp

set service dhcp-server shared-network-name mydhcp subnet 192.168.0.0/24

set service dhcp-server shared-network-name mydhcp subnet 192.168.0.0/24 default-router 192.168.0.1

set service dhcp-server shared-network-name mydhcp subnet 192.168.0.0/24 dns-server 192.168.100.1

set service dhcp-server shared-network-name mydhcp subnet 192.168.0.0/24 exclude 192.168.0.1

set service dhcp-server shared-network-name mydhcp subnet 192.168.0.0/24 exclude 192.168.0.10

SET SYSTEM
ip domain-name

hostname

username …password…

ntp server

ip name-server

terminal monitor

clock timezone

set system domain-name

set system host-name

set system login
set system ntp-server

set system name-server

set system syslog console

set system time-zone

logging

logging facility

logging trap

set system syslog host

set system syslog host … facility

set system syslog host….facility…level….

SET PROTOCOLS …
INTERFACES

interface fastEthernet 0/0

ip address 192.168.1.1 255.255.255.0

duplex auto

speed auto

description LAN

no shutdown

set interfaces ethernet eth0 address 192.168.1.1/24

set interfaces ethernet eth0 duplex auto

set interfaces ethernet eth0 speed auto

set interfaces ethernet eth0 description LAN

OSPF

router ospf 1

network 192.168.1.0 0.0.0.255 area 1

log-adjacency-changes

router-id 192.168.1.1

set protocols ospf area 1 network 192.168.1.0/24

set protocols ospf log-adjacency-changes

set protocols ospf parameters router-id 192.168.1.1

STATIC

ip route 0.0.0.0 0.0.0.0 192.168.0.1

set protocols static route 0.0.0.0/0 next-hop 192.168.0.1
RIP

router rip

network 192.168.1.0

set protocols rip network 192.168.1.0/24
SNMP

snmp-server community … ro|rw
snmp-server community … ACL

snmp-server location

snmp-server contact

set protocols snmp community … authorization ro|rw

set protocols snmp community … client

set protocols snmp location

set protocols snmp contact


Leave a Comment

Ваш e-mail не будет опубликован. Обязательные поля помечены *

Загрузка...
Menu Title